delta3d

 Forum Index >  > SimCore Support New Topic Post Reply
 [Solved] Help Building Delta 3D with cmake
   
ETUSI
 04/24/2009 10:56AM (Read 3700 times)  
+----
Newbie

Status: offline


Registered: 04/24/2009
Posts: 4
Hi,

I am trying to build Delta 3d but have come accross some problems. I am using the tutorial for visual studio 09 found here : http://delta3d.wiki.sourceforge.net/Visual+Studio+2008+%28with+Delta3D+svn-trunk%29.

I have completed steps 1-4 but im having an issue with step 5. I have downloaded cmake (2.6-patch 3), and after running the GUI, selected cmakelists.txt from the d3d installation and dragged this into the window. I have then clicked configure and selected "Visual Studio 9 2008" and hit finish. At this point i get the following error



and at the bottom

PHP Formatted Code
Check for working C compiler: cl
Check for working C compiler: cl -- broken
CMake Error at G:/Program Files/CMake 2.6/share/cmake-2.6/Modules/CMakeTestCCompiler.cmake:32 (MESSAGE):
  The C compiler "cl" is not able to compile a simple test program.

  It fails with the following output:

   Change Dir: G:/Program Files/Delta3D_REL-2.2.0/VS09/CMakeFiles/CMakeTmp

 
  Run Build Command:G:PROGRA~1MICROS~1.0Common7IDEdevenv.com
  CMAKE_TRY_COMPILE.sln /build Debug /project cmTryCompileExec

 
  Microsoft (R) Visual Studio Version 9.0.21022.8.

  Copyright (C) Microsoft Corp.  All rights reserved.


  The following files were specified on the command line:
        CMAKE_TRY_COMPILE.sln

  These files could not be found and will not be loaded.

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:113 (PROJECT)
 


Clicking configure once more highlights the following 2 options in red with the values not found.

CMAKE_CXX_COMPILER_WITH_PATH CMAKE_CXX_COMPILER_WITH_PATH-NOTFOUND
CMAKE_C_COMPILER_WITH_PATH CMAKE_C_COMPILER_WITH_PATH-NOTFOUND

also not highlighted in red but showing not found is:

CMAKE_LINKER CMAKE_LINKER-NOTFOUND

I have tried changing these values manually to point to the MS VS09 compiler C:/Program Files/Microsoft Visual Studio 9.0/VC/bin/cl.exe and also the linker to C:/Program Files/Microsoft Visual Studio 9.0/VC/bin/link.exe but i still recieve the same error message as before.

Can anybody suggest a solution for my issue, as far as i am aware i have completed all necessary steps but is there something i have missed? Any help apprechiated.

Cheers,
Sam.

 
Profile Email
 Quote
ETUSI
 04/24/2009 11:18AM  
+----
Newbie

Status: offline


Registered: 04/24/2009
Posts: 4
It appears the issue im having is similar to that which has been posted in the following thread http://www.delta3d.org/forum/viewtopic.php?forum=14&showtopic=15501. I will try the solution suggested there.

 
Profile Email
 Quote
ETUSI
 04/24/2009 04:58PM  
+----
Newbie

Status: offline


Registered: 04/24/2009
Posts: 4
The issue has now been solved.

For anyone else with a similar issue the fix mentioned in this thread was the solution.

http://www.delta3d.org/forum/viewtopic.php?forum=14&showtopic=15501

Cheers

 
Profile Email
 Quote
Content generated in: 0.31 seconds
New Topic Post Reply

Normal Topic Normal Topic
Sticky Topic Sticky Topic
Locked Topic Locked Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Anonymous users can post 
Filtered HTML Allowed 
Censored Content 

Twitter

User Functions





Don't have an account yet? Sign up as a New User

Lost your password?